Toolbar
The tool bar is located at the top of the editor no matter which mode you are in.

Editor Menu

The editor menu is located to the left of the transform tools menu. This menu allows you to change the file name, select your revision history, as well as link you to the help center and feedback page.

Transform Tools menu

The Transform Tools menu houses tools that allow you to alter the transform properties of an object directly on the Stage.
The Select tool allows you to click and drag in an empty space to select multiple objects with a marquee. You can also click and drag directly on items to manipulate them. In most cases, you'll probably be using the Select tool.
When you have objects selected with the Select tool, you'll see the Gizmo which gives you the power to change the position, scale, and rotation of the object.

Artboard Menu

The artboard menu houses the tools you'll need to create new artboards, nest existing artboards, and create groups.

Create Tools menu

The Create Tools menu is located on the toolbar, just to the right of the Transform Tools menu. This menu houses all of the tools that you need to create vector graphics.

Artboard Menu

The Artboard menu houses all of the tools you need to create new Artboards, nest existing ones, and create groups.
Use the Download menu to download your file, ready to use with our runtimes.
Use the Share Link option to generate a shareable link to your file. This is great if you want to share a file with your client, or as a way to embed your file.

Create Tools menu

The Create Tools menu houses all of the tools you'll need to create vector artwork.

Bones Menu

The bones menu houses both the bone tool and weight tool.

Export menu

The Export menu allows you to export your file in various ways to meet your needs.
The Download menu gives you the option to export your file, ready to use with our runtimes.
Use the Share Link option to create a shareable link that is viewable by anyone with the link, including non-Rive members. This is a great way to share progress with a client or embed your file.
Publish to Community allows you to post your animations and State Machines to the community.
The cloud renderer allows you to export your animations as a variety of file formats such as MP4 and gif.

View Options menu

The View Options menu is located on the right side of the toolbar. This menu allows you to customize your window so that you can see exactly what you want when you want.

Mode toggle

Located above the inspector. The mode toggle allows you to switch between Design and Animate mode. Press Tab to quickly switch modes.